drehbares 3D-Säulendiagramm

Die Aufbereitung von Zahlen und deren Veranschaulichung ist eine der häufigsten Tätigkeiten des Controllers. MS Excel bietet dabei viele Hilfsmittel um die Daten entsprechend gut darzustellen. In diesem Excel-Tipp wird gezeigt, wie Säulendiagramme in 3D und mit einigen Funktionen effektvoll dargestellt werden können. 

Hierfür sollen als Datengrundlage die Umsätze von verschiedenen Jahren unterteilt nach Regionen aufbereitet werden. Der Controller möchte dabei die Umsätze einmal im Vordergrund nach Jahren analysieren und einmal nach Region, zudem möchte er bestimmte Regionen ein- und ausblenden können. Die folgende Tabelle enthält die Beispieldaten. 

Grunddaten 
Abbildung 1 Datengrundlage 


Bis Excel 2003: Ab Excel 2007:
Im ersten Schritt soll ein einfaches 3D-Säulendiagramm erstellt werden. Hierfür wird im Menu „Einfügen“ der Punkt „Diagramm…“ gewählt. Daraufhin wird im neuen Fenster im Bereich Säulendiagramme der Diagrammtyp 3D-Säulen gewählt. Im Datenbereich wird dann der gesamte Bereich von Zelle B2 bis F5 selektiert. Die Auswahl wird mit der Schaltfläche „Fertig stellen“ bestätigt. Abbildung 2 zeigt das erzeugte Diagramm. Im ersten Schritt soll ein einfaches 3D-Säulendiagramm erstellt werden. hierfür wird im Register "Einfügen" im Bereich "Diagramme" bei den Säulendiagrammen das 3D-Säulen-Diagramm gewählt. Im Register Diagrammtools klicken Sie auf "Daten auswählen". Danach wird im Feld "Diagrammdatenbereich:" der gesamte Bereich von Zelle B2 bis F5 selektiert. Die Auswahl wird mit der Schaltfläche "Ok" bestätigt. Abbildung 2 zeigt das erzeugte Diegramm
abb2-grunddiagramm-3dsaeule-klein.jpg
Abbildung 2 3D-Säulen Diagramm statisch
Abb-2-Saulen-statisch-excel-2010-kl.jpg
Abbildung 2 3D-Säulen Diagramm statisch


Da dieses Diagramm statisch ist und somit schwerer zu deuten, sollen zunächst ausgewählte Umsatzregionen ausgeblendet werden. Hierfür sollen Checkboxen angewendet werden. Dafür werden mit der Steuerelemente-Toolbox drei Checkboxen erstellt. Im Anschluss werden in den Zellen A8 bis A10 die Namen ZeigeRegion1 bis 3 für die linked Cells der Boxen definiert und den einzelnen Boxen hinzugefügt werden. Weitere Informationen zu Steuerelemente finden Sie im Excel-Tipp Steuerelemente anwenden. Die Bezeichnung der Checkboxen kann bei Bedarf vorgenommen werden. In diesem Beispiel wird die Bezeichnung der Regionen verwendet.

Im Anschluss muss eine neue Datentabelle erzeugt werden, die beachtet, ob der Graph anzeigt werden soll oder nicht. Hierfür wird auf die Daten der Grundtabelle zurückgegriffen. Die Zelle C7 enthält die Formel =C2. Diese wird mithilfe der Drag&Drop Funktion von MS Excel bis in F7 kopiert. Dabei sollte sich die Formel an die entsprechende Spalte anpassen, sodass in F7 die Formel =F2 steht. Mit den Regionen wird ähnlich verfahren. Dabei wird in die Zelle B8 die Formel =B3 geschrieben und entsprechend nach unten kopiert. Für die Umsatzzahlen müssen folgende Formeln eingegeben werden:

Excel 2003:

C D E F
8 =WENN(ZeigeRegion1;C3;#NV) =WENN(ZeigeRegion1;D3;#NV)
=WENN(ZeigeRegion1;E3;#NV) =WENN(ZeigeRegion1;F3;#NV)
9 =WENN(ZeigeRegion2;C4;#NV) =WENN(ZeigeRegion2;D4;#NV)
=WENN(ZeigeRegion2;E4;#NV) =WENN(ZeigeRegion2;F4;#NV)
10 =WENN(ZeigeRegion3;C5;#NV) =WENN(ZeigeRegion3;D5;#NV)
=WENN(ZeigeRegion3;E5;#NV) =WENN(ZeigeRegion3;F5;#NV)

Excel 2007:

C D E F
8 =WENN(ZeigRegion1;C3;#NV) =WENN(ZeigRegion1;D3;#NV)
=WENN(ZeigRegion1;E3;#NV) =WENN(ZeigRegion1;F3;#NV)
9 =WENN(ZeigRegion2;C4;#NV) =WENN(ZeigRegion2;D4;#NV)
=WENN(ZeigRegion2;E4;#NV) =WENN(ZeigRegion2;F4;#NV)
10 =WENN(ZeigRegion3;C5;#NV) =WENN(ZeigRegion3;D5;#NV)
=WENN(ZeigRegion3;E5;#NV) =WENN(ZeigRegion3;F5;#NV)


Die fertige Tabelle sieht wie folgt aus. Dabei können die Checkboxen auch in der Nähe des Diagramms erstellt werden, als Funktionsschaltflächen. In der gezeigten Tabelle ist die zweite Region ausgeblendet. Im darunter befindlichen Diagramm ist der Effekt zu sehen.

abb3-tab-dia-ausblender-3dsaeule-kl.jpg
Abbildung 3 Datentabelle 1 mit Diagramm
Abb-3-Datentabelle-1-mit-Diagramm-excel-2010-kl.jpg
Abbildung 3 Datentabelle 1 mit Diagramm


Als letzte Option soll eine Drehfunktion im Diagramm erzeugt werden. Dabei ist der hier beschriebene Aufbau an einige Grenzen gebunden.

  1. Die Grundtabelle sollte in der Anzahl der Spalten und Zeilen identisch bzw. möglichst gleich sein.
  2. Wenn die Tabelle unterschiedlich in der Anzahl von Spalten und Zeilen ist, werden im jeweils kleineren Bereich leere Datenreihen entstehen.
  3. Die Spalten- und Zeilenbeschriftungen dürfen keine Zahlen enthalten.

Im ersten Schritt wird mithilfe der Steuerelemente-Toolbox ein Drehfeld erzeugt. Hierbei muss beim Erstellen, darauf geachtet werden, dass dieses Feld breiter als hoch ist. In den Eigenschaften des Drehfeldes wird der Wert für max auf 1 gesetzt und für min auf 0. Zusätzlich wird die Zelle H51 in Drehungnummer (im Excel 2010 Beispiel ist der Name Drehungsnummer) umbenannt und als LinkedCell festgesetzt.

Hiernach wird die Datentabelle aus der Tabelle 1 mithilfe der Funktion MTRANS transponiert. Dabei müssen Array-Funktionen angewendet werden. Dies erfolgt durch die Bestätigung der Formeln mit STRG + Shift + Enter anstatt nur Enter.

Im ersten Schritt werden die Zellen C12 bis E12 markiert. Dann wird folgende Formel als Array-Funktion eingetragen.

=MTRANS(B8:B10)

Wenn dies erfolgreich war, steht in den Zellen C12 bis E12 diese Formel {=MTRANS(B8:B10)}. Im nächsten Schritt wird der Zellbereich von B13 bis B16 markiert und mit folgender Array-Funktion gefüllt.

=MTRANS(C7:F7)

Danach wird der Zellbereich markiert, in dem die Werte von Region 1enthalten sind. Dabei handelt es sich um die Zellen von C13 bis C16. In diesen Bereich wird diese Array-Funktion =WENN(A8=WAHR;MTRANS(C8:F8);#NV) geschrieben. Für den Bereich von D13 bis D16 ist die Formel =WENN(A9=WAHR;MTRANS(C9:F9);#NV) und für den Bereich E13 bis E16 ist die Formel =WENN(A10=WAHR;MTRANS(C10:F10);#NV).

Nachdem die zweite Wertetabelle erzeugt worden ist, wird die Datentabelle für das endgültige Diagramm erzeugt. Diese Datentabelle greift je nach Fall auf die eben erzeugte Tabelle oder auf die Tabelle 1 zurück. Dafür werden folgende Wenn-Funktionen in die Tabelle geschrieben.


B C D E F
18
=WENN(
Drehungnummer=0;
C7;C12)
=WENN(
Drehungnummer=0;
D7;D12)
=WENN(
Drehungnummer=0;
E7;E12)
=WENN(
Drehungnummer=0;
F7;F12)
19 =WENN(
Drehungnummer=0;
B8;B13)
=WENN(
Drehungnummer=0;
C8;C13)
=WENN(
Drehungnummer=0;
D8;D13)
=WENN(
Drehungnummer=0;
E8;E13)
=WENN(
Drehungnummer=0;
F8;F13)
20 =WENN(
Drehungnummer=0;
B9;B14)
=WENN(
Drehungnummer=0;
C9;C14)
=WENN(
Drehungnummer=0;
D9;D14)
=WENN(
Drehungnummer=0;
E9;E14)
=WENN(
Drehungnummer=0;
F9;F14)
21 =WENN(
Drehungnummer=0;
B10;B15)
=WENN(
Drehungnummer=0;
C10;C15)
=WENN(
Drehungnummer=0;
D10;D15)
=WENN(
Drehungnummer=0;
E10;E15)
=WENN(
Drehungnummer=0;
F10;F15)
22 =WENN(
Drehungnummer=0;
"";B16)
=WENN(
Drehungnummer=0;
#NV;C16)
=WENN(
Drehungnummer=0;
#NV;D16)
=WENN(
Drehungnummer=0;
#NV;E16)
=WENN(
Drehungnummer=0;
#NV;F16)


Hiernach wird das endgültige Diagramm eingefügt, welches die Drehung und ausblenden benutzt. Beim Einfügen wird der Datenbereich von B18 bis F22 genutzt. Nachdem das Diagramm erzeugt wurde, müssen dynamische Bereiche angelegt werden (siehe auch Excel-Tipp Erzeugen Sie dynamische Diagramme).

Folgende vier Namen mit diesen Formeln werden definiert, der Name Tabelle1 wurde in der Beispieldatei entsprechend den Tabellenblattnamen angepasst..

Dia1Reihe1: =BEREICH.VERSCHIEBEN(Tabelle1!$C$19;;;;ANZAHL2(Tabelle1!$C$18:$F$18)-ANZAHL(Tabelle1!$C$18:$F$18))
Dia1Reihe2: =BEREICH.VERSCHIEBEN(Tabelle1!$C$20;;;;ANZAHL2(Tabelle1!$C$18:$F$18)-ANZAHL(Tabelle1!$C$18:$F$18))
Dia1Reihe3: =BEREICH.VERSCHIEBEN(Tabelle1!$C$21;;;;ANZAHL2(Tabelle1!$C$18:$F$18)-ANZAHL(Tabelle1!$C$18:$F$18))
Dia1Reihe4: =BEREICH.VERSCHIEBEN(Tabelle1!$C$22;;;;ANZAHL2(Tabelle1!$C$18:$F$18)-ANZAHL(Tabelle1!$C$18:$F$18))


Die nachfolgenden Abbildungen zeigen die Datentabellen mit dem Diagramm vor und nach einer Drehung.

abb4-part1-3dsaeule-mit-effekt-kl.jpg
Abbildung 4.1 Diagramm mit Effekt vor einer Drehung
Abb-4-fertiges-diagramm-part1-kl.jpg
Abbildung 4.1 Diagramm mit Effekt vor einer Drehung
abb4-part2-3dsaeule-mit-effekt-kl.jpg
Abbildung 4.2 Diagramm mit effekt nach einer Drehung
Abb-4-fertiges-diagramm-part2-kl.jpg
Abbildung 4.1 Diagramm mit Effekt nach einer Drehung


Die Darstellung von Effekten in einen Diagramm ist sehr begrenzt. Aufgrund der Formeln und der festgesetzten Anzahl an Datenreihen, kommt es bei bestimmten Perspektiven zu unsauberen Darstellungen. Um dies zu vermeiden ist die Anwendung von VBA an dieser Stelle zu empfehlen.


Die Beispieldatei 3D-Säulendiagramm können Sie hier herunterladen >>

 

 


 

Informieren Sie sich regelmäßig über neue Excel-Tipps  und Excel-Tools
in unserem monatlich erscheinenden  >>Newsletter<<.

 


letzte Änderung A.W. am 09.09.2019
Autor(en):  Alexander Wildt

RSS

Der Autor:
Herr Alexander Wildt
Unser Excel-Experte Herr Dipl. Betriebswirt Alexander Wildt verfügt über mehrjährige Erfahrungen in der Erstellung professioneller Excel-Lösungen im betriebswirtschaftlichen Bereich und in der Beratung unserer Kunden bei der Anwendung der Tools aus unserer eigenen Vermarktung.
Homepage | Club-Profil | weitere Fachbeiträge | Forenbeiträge | Blog | Fotogalerie
Literaturhinweise
Excel-Tools

Weitere Fachbeiträge zum Thema

Premium-Stellenanzeigen


Landkreis Potsdam-Mittelmark
Bad Belzig
Eura Mobil GmbH
Sprendlingen
HUK-COBURG VVaG
Coburg
walter services GmbH
Siegburg
HUK-COBURG Autowelt GmbH
Düsseldorf

Eigenen Fachbeitrag veröffentlichen? 

Sie sind Autor einer Fachpublikation oder Entwickler einer Excel-Vorlage? Gern können Sie sich an der Gestaltung der Inhalte unserer Fachportale beteiligen! Wir bieten die Möglichkeit Ihre Fachpublikation (Fachbeitrag, eBook, Diplomarbeit, Checkliste, Studie, Berichtsvorlage ...) bzw. Excel-Vorlage auf unseren Fachportalen zu veröffentlichen bzw. ggf. auch zu vermarkten. Mehr Infos >>

Kommentar zum Fachbeitrag abgeben

Nur registrierte Benutzer können Kommentare posten!