SVERWEIS – Die Funktion der Controller

Mit der Tabellenfunktion SVERWEIS können Sie einen Wert über einen Suchbegriff aus einem Datenbereich ermitteln und ausgeben. Die genaue Funktionsweise erklärt sich am Besten aus der Syntax heraus:

=SVERWEIS(Suchkriterium;Matrix;Spaltenindex;Bereich_Verweis)

Das Argument Suchkriterium ist der Wert, welcher in der ersten Matrixspalte gefunden werden soll. Suchkriterium kann ein Wert, ein Bezug oder eine Textzeichenfolge sein. Das Argument Matrix ist die Tabelle mit Informationen, in der die Daten gesucht werden. Das Argument Spaltenindex ist die Spaltennummer innerhalb der Matrix, aus welcher der entsprechende Wert zurückgegeben werden muss. Ein Spaltenindex von 1 gibt den Wert der ersten Spalte der Matrix zurück; ein Spaltenindex von 2 gibt den Wert der zweiten Spalte der Matrix zurück. Das letzte optionale Argument ist Bereich_Verweis. Wenn dieses Argument WAHR ist, müssen die Werte in der ersten Spalte der Matrix in aufsteigender Reihenfolge angeordnet werden. Wenn Bereich_Verweis den Wert FALSCH aufweist, muss die Tabelle nicht sortiert vorliegen. 



Wenn Sie sich die Abb. 5 ansehen, dann haben Sie die Ausgangssituation vor Augen. Sie sehen im oberen Bereich eine Tabelle, in der die Arbeitsstunden pro Mitarbeiter und Tag aufgeführt werden. Die Aufgabe besteht nun darin, über den Wochentag und den Mitarbeiternamen die gearbeiteten Stunden zu ermitteln. Dabei muss der Bereich C9:C12 gefüllt werden. Setzen Sie hierfür die Tabellenfunktion SVERWEIS in Verbindung mit der Funktion VERGLEICH ein:

  1. Markieren Sie den Zellenbereich C9:C12.
  2. Erfassen Sie die Formel =SVERWEIS(A9;$A$1:$F$5;VERGLEICH(B9;$A$1:$F$1;0);FALSCH) (siehe Abb. 6.)
  3. Drücken Sie anschließend die Tastenkombination S+Ü.



Als Ergebnis erhalten Sie wie gewünscht die Arbeitsstunden des Mitarbeiters am jeweiligen Wochentag.


Mehr exklusive Excel-Tipps erhalten Sie im neuen Spezialdienst "Excel Formel Ticker ". Klicken Sie hier für weitere Informationen!


letzte Änderung am 24.07.2018
Quelle:  Excel Praxis für Controller

RSS
Literaturhinweise
Excel-Tools

Weitere Fachbeiträge zum Thema

Kommentar zum Fachbeitrag abgeben

29.04.2010 00:48:00 - Thomas

Haben Sie dies mal bei einer 6-8MB grossen Datei mit 4-5 Blätter versucht? Lieber Ladebalken .... wenn Sie all dieses verküpfungen Aktualisieren. Bis 1MB geht das ja noch zügig aber dann! Ich habe Intel duo Core mit 2GB Ram. LG Thomas
[ Zitieren | Name ]

30.04.2010 08:07:14 - redaktion

Sehr geehrter Nutzer, in diesem Beitrag soll die funktionweise von Sverweis vorgestellt werden. Sie haben natürlich Recht, das bei großen Datenmengen diese Funktion sehr schnell zu langen Rechenzeiten führt. Wir empfehlen daher bei größen Datenmengen auf eine VBA Lösung umzuschwenken. Mit freundlichen Grüßen Die Controlling-Portal.de Redaktion
[ Zitieren | Name ]

28.03.2011 13:39:27 - Gast

Hallo Brauche Hilfe Habe zwei XLS. Möchte wenn die Werte in Spalte (A aus XLS1) gleich dem in XLS2 Spalte x ist die Inhalte der Spalte Y aus XLS in XLS2 schreiben, wie geht so etwas? Mit SVERWEIS Danke u. Gruß Rolf
[ Zitieren | Name ]

28.03.2011 14:20:39 - Redaktion

Sehr geehrter Nutzer, um eine möglichst schnelle Antwort zu erhalten, empfehlen wir Ihr Anliegen im Controlling-Portal.de Forum zu schreiben. Dort helfen Ihnen die anderen Nutzer gerne und bestimmt wird dort auch eine Lösung gefunden. Mit freundlichen Grüßen Die Controlling-Portal.de Redaktion
[ Zitieren | Name ]

15.11.2011 13:50:56 - Gast

Die Seite ist echt super!
[ Zitieren | Name ]

20.07.2012 11:44:54 - Gast

Hallo zusammen ich habe eine Kostenmatrix erstellt. Kosten ziehen sich aus anderen Excel-Dateien via SVERWEIS. Wenn ich aber in der anderen Datei die Kosten ändere, speicher, schließe und meine Kostenmatrix öffne, aktualisieren sich die Kosten nicht entsprechend. Auch nicht, wenn ich F9 drücke. Lediglich, wenn ich in die einzelnen Zellen bzw in die Formel gehe und dann Enter drücke (also die Formel "neu eingebe"), dann aktualisieren sich die Zahlen .... Gibt es eine Alternative? Es handelt sich um mehrere hundert Zellen, die möchte ich nicht alle einzeln anklicken müssen ;) Liebe Grüße
[ Zitieren | Name ]

Nur registrierte Benutzer können Kommentare posten!