Gesuchte Zeichenketten in Ihren Listen zählen

So zählen Sie, wie oft Zeichenfolgen in Ihren Listen auftreten.

Ob Artikelnummer, Bestellcodes oder andere Informationen: Nicht nur Zahlen müssen mit Excel verarbeitet werden. Sie möchten das Auftreten bestimmter Zahlenfolgen oder Buchstabenfolgen in Ihren Tabellen zählen? Über eine Matrixformel überprüfen Sie einen Zellbereich und zählen die Zellen, in denen eine bestimmte Zeichensequenz vorkommt. Die Matrixformel ist folgendermaßen aufgebaut:

=SUMME(WENN(ISTFEHLER(FINDEN(Zeichenfolge;Bereich));0;1))

Bereich legt die Zellen fest, die Sie überprüfen möchten. Geben Sie hier einen Zellbereich Ihrer Wahl an, beispielsweise A1:A10.
Mit dem Parameter Zeichenfolge legen Sie fest, nach welcher Text- oder Ziffernfolge Sie suchen möchten. Diesen Parameter übergeben Sie in Anführungszeichen, beispielsweise "123".
Mit der folgenden Formel zählen Sie beispielsweise wie viele Zellen im Bereich A1:A10 die Zeichenkette "123" enthalten:

=SUMME(WENN(ISTFEHLER(FINDEN("123";A1:A10));0;1))

Die Formel sucht über die FINDEN-Funktion nach der Zeichenkette. Dann werden die Ergebnisse für den Bereich gezählt, bei denen ISTFEHLER für das FINDEN-Ergebnis keinen Fehlerwert liefert. Die folgende Abbildung zeigt die Formel im Praxiseinsatz:



Beachten Sie bei der Eingabe der Formel, dass es sich um eine Matrixformel handelt. Matrixformeln erkennen Sie an den geschweiften Klammern, mit denen Excel sie automatisch einrahmt.  Im Gegensatz zu den normalen Formeln, die nur mit der Taste EINGABE beendet werden, schließen Sie Matrix-Formeln mit STRG UMSCHALT EINGABE ab. Hinweis: mit UMSCHALT ist die Taste gemeint, die Sie gemeinsam mit einer Buchstabentaste drücken müssen, um einen Großbuchstaben zu erzeugen.


Mehr exklusive Excel-Tipps erhalten Sie im neuen Spezialdienst "Excel Formel Ticker ". Klicken Sie hier für weitere Informationen!


letzte Änderung am 24.07.2018
Quelle:  Excel Praxis für Controller

RSS
Literaturhinweise
Excel-Tools

Weitere Fachbeiträge zum Thema

Premium-Stellenanzeigen


Fraunhofer-Institut für Intelligente Analyse- und Informationssysteme IAIS
Sankt Augustin
HUK-COBURG Versicherungsgruppe
Coburg
Meteor GmbH
Bockenem
Captrain Deutschland GmbH
Berlin
Gebr. Brasseler GmbH & Co. KG
Lemgo

Eigenen Fachbeitrag veröffentlichen? 

Sie sind Autor einer Fachpublikation oder Entwickler einer Excel-Vorlage? Gern können Sie sich an der Gestaltung der Inhalte unserer Fachportale beteiligen! Wir bieten die Möglichkeit Ihre Fachpublikation (Fachbeitrag, eBook, Diplomarbeit, Checkliste, Studie, Berichtsvorlage ...) bzw. Excel-Vorlage auf unseren Fachportalen zu veröffentlichen bzw. ggf. auch zu vermarkten. Mehr Infos >>

Kommentar zum Fachbeitrag abgeben

Nur registrierte Benutzer können Kommentare posten!